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Introducing Visual
Man-Machine
Interface (VMMI)

Introducing VMMI

Visual Man-Machine Interface (VMMI) is a Microsoft Windows-based menu-driven

application that allows you to enter choices in dialog boxes to program directly or

indirectly to the communications system. VMMI is designed as Common Code Base

software (that is, interchangeable among DXP, DXP Plus, FXS, FXT and FX II). VMMI

allows on-line programming without additional communications software and allows

creation of databases off-line. VMMI allows you to archive and restore databases to the

system and translates earlier databases. Logical board assignments allow you logically to

assign the boards before you physically assign the boards. VMMI is only available with

Common Code Base (CCB) software Rev. 10A and later.

VMMI has drop-down menus like other windows-based software (for example,

wordprocessors and spreadsheets). Use your computer’s mouse to move the cursor to the

desired location, and either click or double-click the left mouse button to select the

desired programming option.

VMMI allows you directly to connect to the communications system and program it

on-line. Alternately, you can program a database off-line, save it, and upload it in the

communications system later.

For general understanding on how to use VMMI to program a digital communications

system, refer to Chapter 7 - Programming with VMMI on page 31.

Introducing VMMI – 1
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Determining Your Equipment Needs

Use VMMI to program the digital communications system from a personal computer (PC)

that meets the following requirements:

• A processor (a minimum requirement––486 recommended),

• 3.5–inch floppy disk drive,

• Hard drive with at least 80 megabytes of storage capacity,

• Available 9–pin or 25–pin serial data port (required for communications with system),

• A mouse that Microsoft Windows 95, Windows 98, Windows 2000, and Windows NT

operating software support (optional but highly recommended for Microsoft Windows

operation),

• VGA color monitor (highly recommended—VGA monochrome acceptable),

• Microsoft® Windows, version 95, 98, 2000, or NT operating system,

• VMMI program disks.

2 – Determining Your Equipment Needs
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Installing the VMMI
Program Software

The VMMI software is your entry to the communications system. Before you can log into

the system, you must first load the VMMI program on your computer’s hard drive. When

installing the VMMI software, you do not need to have your computer connected to the

system equipment.

Loading VMMI with Windows 95, 98, 2000, and NT

1. Turn on your PC.

2. After the Windows Desktop appears, insert the program disk in your computer’s disk
drive.

3. From the Windows Desktop, click Start, and then click Run.

4. At the prompt dialog box, type A:\setup, and click OK.

5. Add information as required to any additional prompt lines that may appear on your
screen.

6. The Install program creates a program group and an icon in the Start menu under
the Programs title.

Loading VMMI with Windows 95, 98, 2000, and NT – 3
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Connecting to the
System

Physical Connection

Connecting a PC to the FX System

CAUTION

The system will reset itself every hour until you turn on the system software as
described in the paragraph titled, Turning on the System Software.

For VMMI programming on the FXS system, make the following initial cable connections:

• Connect the supplied serial data cable (JK504-002) between the PC portion’s COM1

serial data port and the telephony portion’s COM1 serial data port. This connection

provides the initial path between the PC portion and the telephony portion for turning

on the system software, programming the telephony portion’s database, and arranging

the system for using pcANYWHERE for remote maintenance of the PC portion. After

you finish these operations, you can arrange the operational connections described in

the later paragraph titled, Making the Operational Connections.

• For VMMI programming on the FXT or FX II system, connect the serial data port of the

external PC to the COM1 serial data port on the cabinet.

NOTE: Default values for the serial data port on the FX systems are 19200 baud, eight data bits, one stop bit,
and no parity bit.

Physical Connection – 5
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6 – Physical Connection

GCA40–182 Connecting to the System

Pin 1 = Request to Send
Pin 2 = Clear to Send
Pin 3 = Receive Data
Pin 4 = Transmit Data
Pin 5 = Signal Ground
Pin 6 = Frame Ground

NOTES:
1. Maximum distance between the serial data ports and the

external data equipment is based on the baud rate of the port.
The distance is limited to 50 feet when the port is operated at
19,200 baud and 500 feet when it is operated at speeds up to 9600 baud.

2. Some data devices require the CTS signal for proper operation.
Route CTS to the device as needed.
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Connecting a PC to the DXP Plus

Connect the serial data port of the PC to the maintenance port of the DXP Plus central

processor unit (CPU) board. The maintenance port is a dedicated serial data port reserved

exclusively for system programming.

The default data formats of these serial data ports are shown in the following chart.

Port Type Baud Rate Data Bits Stop Bits Parity

Maintenance
Port

9600 8 1 None

Modem Port 2400 8 1 None

Note: The recommended baud rate is 19200 bps.

You can connect the PC remotely through a telephone line to the DXP Plus using

customer-supplied modems at both the PC and the DXP Plus common equipment. The

DXP Plus includes its own modem that you can connect between the CPU board’s modem

port and an outside telephone line.

Physical Connection – 7
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Connecting a PC to the DXP

Connect the serial data port of the PC to either of the serial data ports that the DXP

provides on the CPU board. The system designates these modular jacks as RS–232 1 and

RS–232 2.

The default data format of the RS–232 1 and RS–232 2 data ports is shown in the

following chart.

Port Type Baud Rate Data Bits Stop Bits Parity

RS–232 1 9600 8 1 None

RS-232 2 300 7 2 None

If you have used the two CPU-provided serial data ports for connecting other DXP

features (such as the PC Attendant Position and a serial data printer), you can add a

communications card to the DXP and connect the programming PC to a serial data port

that the card provides. See your DXP System Hardware Instructions (the Volume I binder)

for complete installation details.

8 – Physical Connection
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Making the Programming Connection to the System

Once you have loaded the software and made the necessary physical connections between

the PC and the communications system equipment, you can make the program

connection to the system by doing the following procedure.

1. Turn on your PC and load Windows.

2. Select Start | Programs | Vmmi | VMMI. The computer runs the installed VMMI
software program.

3. On the Switch menu, click Connect to.

4. Select either Administrator or Installer and type the appropriate password. The
system defaults all passwords; however, you can customize the passwords as part of
VMMI programming if you wish.

5. Select the communications port that your PC uses to communicate with the
communications system.

6. If you are operating remotely through a modem, check the modem prompt.

7. Select the serial data parameters that match the requirements for the system (or for
the modem if you are connected remotely through a modem). To speed up the data
transfer process, you should use a data speed of 19.2 Kbs (kilobits per second) for the
DXP Plus, FXS and FXT Systems, and 9600 bit per second for the DXP. If you plan
to operate at this higher data speed,
first connect at the default rate, then
use the VMMI programming menu to
change the data parameters of the
system, and finally use the Switch
menu to reconnect at the higher speed.

Note: A data speed of 19.2 might not operate
reliably through modem connections. In
addition, both modems must support the
higher data speed. The DXP Plus internal
modem does not support data speeds above
2400 Kbs at this time.

8. When you finish making the
connection settings, click the Connect
button to return to the Switch menu.
The system responds by presenting its
serial number at the bottom of the
VMMI screen for your reference, and shows an on-line message.

Note: If the system does not complete the connect procedure, check your cable connections, verify your serial
data settings, and repeat the log in procedure.

9. Use the Switch menu to disconnect from the system, archive or restore a system
database, or download system software.

Making the Programming Connection to the System – 9
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Archiving and
Restoring an
Existing Database

You can use the software to archive (download) and restore (upload) the system’s

database. To archive and restore data, your PC must be connected to the system.

Using VMMI to Archive an Existing Database

Archive a Database

1. Turn on your PC.

2. Select Start | Programs | Vmmi | VMMI.

3. On the Switch menu, click Connect to.

4. On the Connect To Remote System dialog box, click Connect. The program is
connected to the communications system and returns to the window.

5. On the Switch menu, click Archive Database.

6. Choose a memory storage location for the archive operation and OK your choice.
Since the database can be quite large, you should choose a location on your
computer’s hard drive to ensure that you have enough memory to store the database.

7. The system automatically archives the database.

Using VMMI to Archive an Existing Database – 11
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Using VMMI to Restore an Existing Database

Restore a Database

1. Turn on your PC.

2. Select Start | Programs | Vmmi | VMMI.

3. On the Switch menu, click Connect to.

4. On the Connect To Remote System dialog box, click Connect. The program is
connected to the communications system and returns to the window.

5. On the Switch menu, click Restore Database.

6. Choose Restore Complete Database and click OK.

7. Choose the memory storage location that contains an archived database and OK your
choice.

8. The system automatically restores the database.

9. Reset the system after you restore the database.

12 – Using VMMI to Restore an Existing Database
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Upgrading System
Software

Upgrading FX System Software

Comdial manufacturing technicians load the FX System’s operating software. They also

load the upgrade software that you use to obtain your key number. You need the key

number to activate the system operating software. Once you obtain your key number and

enter it in the upgrade software, the system automatically accesses the key through

internal software mechanisms.

CAUTION

You must obtain your key number to operate the telephony portion of the FX

system. Otherwise, the system will reset itself every hour.

NOTE: The Key Update Utility and the portions of the following procedure that apply to CTI applications and
voice mail applications are not part of enabling the system software. You can ignore those parts of the
procedure if they do not apply to your system.

Upgrading FX System Software – 13
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Sequential Software Enabling Details

1. Obtain the software *.BIN file and store it on the PC if you have not already done so.

2. Make a list of the applications that you plan to purchase from Comdial.

3. From Windows Desktop, click the Installation and Maintenance folder then click the
VMMI program.

4. Determine the system serial number.

a. Log into the system with VMMI and view the system serial number at the lower
part of the VMMI window.

Note: Remember, the system operates in a demo mode for one hour before it turns itself off.

5. Stop the installed voice processing system from running.

a. From Windows Desktop, click the Installation and Maintenance folder; select the
Services icon.

b. Highlight Voice Mail Manager, and click Stop.

c. Repeat this procedure to stop the database manager and the FTP server.

6. From Windows Desktop, click the Installation and Maintenance folder then click the
Key Update Utility Program.

7. With the application key installed on the PC’s parallel printer port, run this Key
Update Utility program to determine the CTI application key’s serial number and
current magic number. You need to provide this information to the Comdial
representative so the representative can, in turn, provide the information you need to
turn on the CTI applications.

8. From the Key Update Utility dialog box, click the Examine Key button. The system
responds by displaying the following information in the key update window:

• The CTI application key’s serial number,

• The current magic number of the installed key.

9. Once you know the system’s telephony serial number (and the CTI application
information if needed), contact the Comdial representative:

• 1-800-669-2663 (U.S.A. calls),

• 1-800-978-2290 (international calls).

10.Provide to the representative the following facts:

• System serial number (from step 4),

• Port size of the system (from *.BIN file download –see step 1),

• Feature set wanted (from *.BIN file download–see step 1),

• System software applications wanted (from *.BIN file download–see step 1),

• Standalone features wanted (from *.BIN file download–see step 1),

• CTI applications wanted (if applicable),

• The serial number and magic number from the CTI application key (if applicable),

• Method of payment.

14 – Upgrading FX System Software
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Armed with this information, the Comdial representative, in turn, gives the installer

several encrypted alphanumeric character strings that represent the following items:

• The system software key to enable the telephony system software,

• The CTI application Magic Number

• The completion code needed to verify the operation,

• The NT Renew code to enable the voice processing system.

Record these character strings somewhere so that you will have them available to use as

you finish this procedure.

11.Enter the system software key to enable the telephony system software.

a. Use VMMI to log into the system, on the Switch menu, click Archive Database.

Archive the existing database per the window prompts. If you do not wish to archive the

existing database, skip this step.

b. Use VMMI to log into the system, on the Switch menu, click System Software
Upgrade.

c. On the System Software Upgrade dialog box, click the Provide a New Key box and

type the system software key character sequence.

d. Click Next.

e. Browse for and select the software upgrade *.BIN file that you earlier stored in the
PC.

f. VMMI provides a new window that presents the feature set and release number of
the software upgrade.

g. Click Finish.

h. Observe that the system loads the software and then resets itself.

i. Reconnect VMMI to the system, and restore the archived database or reprogram
the features as needed.

Upgrading FX System Software – 15
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12.Type the CTI application’s new magic number to enable the CTI applications.

a. Return to the Windows Desktop, click the Installation and Maintenance folder,
then click the Key Update Utility program.

b. Type the application’s new magic number character sequence into the update
utility.

c. Click the Update Key button.

The utility menu shows a completion code value to show that the procedure is finished.

Verify that the completion code matches the completion code that the Comdial

representative provided to you.

e. Click Done to end the Key Update Utility session.

13.Type the NT Renew code to enable the voice processing system.

a. Return to Windows Desktop, click the Installation and Maintenance folder, select
the NTRENEW icon.

This action opens the NT Renew dialog box.

b. Type the NT Renew code in the provided box.

c. Click Apply.

The window updates to identify the new voice processing system statistics and access to

optional modules.

d. Click Done to exit the dialog box.

14.Restart the voice processing system.

a. From Windows Desktop, click the Installation and Maintenance folder, select the
Services icon.

b. Highlight Voice Mail Manager, click Start.

c. Repeat this procedure to restart the database manager and the FTP server.

By completing the steps of the above procedure, you enable the system operating software

for the telephony portion of the system, enable the CTI applications that you plan to load

and run on the PC portion of the system, and enable system voice processing.

Because your system arrives as voice mail-ready, there is nothing more that you need to

do to make the voice processing application operational. If you plan to operate other CTI

applications, you must follow the instruction in the next paragraph titled, Loading the CTI

Applications to make those applications operational.
\
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Loading the CTI Applications

After you obtain the magic number from the Comdial representative, your next task is to

install the CTI application software onto the hard drive of the PC. When doing this, there

are several parameters that you must consider.

• You must install the Wideopen.Office application first,

• You must have available several blank, formatted floppy disks (Wideopen.Office and

QuikTrak applications require floppy disks–a prompt appears on the screen when

appropriate),

• You can install only one application at a time,

• You must restart the PC whenever a window’s dialog box prompts you to do so after an

application installation.

Note: Restart the PC from the Start menu and then do the logon and password exercises.

Install the application in the following manner,

1. Be sure that you have installed the CTI application key on the PC’s parallel printer
port.

2. Place the application CD in the PC’s CD drive–it will start automatically in a few
seconds and cause an application installation window to appear on the screen.

3. From the Application Installation window, click on the application to be installed and
click Install.

Keep in mind, the following items:

• You can install only one application at a time.

• You must load Widopen.Office first.

• You must restart the PC whenever a screen dialog prompts you to do so.

• Need floppy disks for Wideopen.Office and QuikTrak installations.

The Wideopen.Office or QuikTrak installation is a two-step process: the system writes to

the floppy disk and then the system installs the application from the disk. The system

prompts you to install the floppy disks as you need them. The system also prompts you to

install the Wideopen.Office or QuikTrak applications after it writes to the floppy disk. Do

this per the following sequence.

a. Select Start | Settings | Control Panel.

b. Select Add | Remove Program icon.

c. Be sure that the floppy disk is in drive A:\.

d. Select Install.

e. Click Next.

f. Click Finish.

g. Remove the floppy disk and restart the PC after the installation.

Upgrading FX System Software – 17
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Note: Some applications require the Key Update Utility program. For those applications, the system prompts
you to accept an automatic install of the Key Update Utility program as part of the installation. Make
your choice, and the application installation occurs automatically after which a dialog box will prompt
you to restart the PC. Remember, remove any installed floppy disk before restarting the PC.

4. Repeat the application load and restart procedure until you have loaded all the
applications that you require.

Note: The dialog boxes as they appear, and follow the displayed instructions.

5. Remove the CD and store it away for future use. Some applications have a server part
and a client part. For those, you must take the CD to the client PC and install that
application there. Again, follow the screen prompts as they appear.

Note: Some applications require specific COM port cable connections for normal operations. Refer to the
paragraph titled, Making the Operational Connections for cabling details.

CAUTION

Always make a complete backup of the system PC’s hard drive contents after you
complete the installation. Afterwards, do regular backup of the PC’s hard drive
contents. The equipment cabinet includes an installed tape drive and a blank
tape cartridge to store the backup data. Use the Windows NT backup utility to
backup the PC’s hard drive. Click Start /Programs and then click on the backup
utility.

18 – Upgrading FX System Software
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Upgrading DXP Plus System Software

The DXP Plus digital communications system includes system software when it ships

from the factory. At initial system installation, you do not need to load system software to

make the system operational. Should you need later to reload the system software (for

software upgrade purposes for example), you can do so using the supplied system

software disk. Use Windows or MS-DOS commands to save the disk’s information from

your computer’s floppy drive to its hard drive. Having the software on your computer’s

hard drive allows the data to load into system memory much quicker than it would from

the computer’s floppy disk drive.

To load the system software information, your PC must be connected to the

communications system.

1. Turn on your PC.

2. Select Start | Programs | Vmmi | VMMI.

3. If you have not previously archived the system database, do so now.

a. On the Switch menu, click Archive Database.

b. Select a storage location for the archive operation and OK your choice. Since the
database can be quite large, you should choose a location on your computer’s
hard drive.

c. The system will archive the database.

4. On the Switch menu, click System Software Upgrade.

5. The system automatically takes itself out of service and makes a backup of its
database. Choose the location where the new software data resides (select disk drive,
directory, and file) and OK your choice. The system loads the software data, reloads
the database that it previously backed up, resets itself, and places itself back in
service.

Upgrading DXP Plus System Software – 19
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Upgrading DXP System Software

The upgrade to software release 10A or later requires that you install a new RAM card

(DXRAM-EXPC) and the software memory card (DXPSWQ-DLRC) on the DXP’s central

processor unit. If you need detailed instructions for doing these operations, refer to your

DXP System hardware instructions.

Converting the DXP Database

Use this procedure to convert an existing DXP database to software release 9n

compatibility. This action places the database in an arrangement that allows you to

translate it. Translating the database makes it compatible with the software releases that

support VMMI usage (software release 10A and later).

Store the Current DXP Database

1. Employ a PC with a XMODEM communications program and use the DXP’s
embedded MMI programming method to store the current DXP database to the PC’s
hard drive. The saved database does not include the SMDA / SMDR records. If you
need these SMDA / SMDR records, you must make a printout of them before you do
the database storage.

2. Disconnect the PC from the DXP.

3. If the stored database is not at least software release 9n, obtain a copy of revision 9A,
or later PCMMI programming software and load it on your computer.

NOTE: Remember, you can download the latest software version, and PC Attendant software from the Comdial
Technical Services Bulletin Board by calling 1-804-978-2583 or from the World Wide Web at
http://bbs.comdial.com.

20 – Upgrading DXP System Software
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Master Clearing the DXP System

If you do not Master Clear the system, it is possible the DXP will not perform properly

with a new memory card. The DXCPU-68K board provides a method for the master clear

to occur automatically at the initial power up after you have changed or upgraded the

software card. When you do an upgrade, you must execute the following sequence of

events exactly as they are stated here.

1. On the DXPCPU-68K
circuit board, set DIP

switch 8 to its ON
position. This step
enables the DXP to do
the master clear and is
a required step;
otherwise, the software
upgrade will not occur
and the system will not
operate.

2. Connect the AC power
cord to the AC outlet
and turn on the AC
power switch. At power
up, the DXP
automatically executes
a master clear
operation. Observe that
the LED indicators on
the DXCPU-68K board,
the DXSRV services
board, and all installed
station and line boards
flash in a random
pattern during the
master clear sequence.
After the master clear
sequence is complete, the indicators on the DXCPU-68K and DXSRV boards turn on
steadily and the indicators on the station and line boards wink ON for four seconds
and OFF for four seconds.

3. After power up, set DIP switch 8 to its OFF position.

4. Press the RESET button on the CPU board to reset the system.

Note: The system does the automatic master clear once following the initial power up after you have upgraded
the software. It will not do an automatic master clear operation again after subsequent power ups.
Because of this, you can leave DIP switch 8 ON if you wish. Leaving it ON will ensure that the DXP will
always power up in a master clear and operation mode after you have done a software upgrade.
However, by turning DIP switch 8 OFF, you prevent the DXP from becoming operational at power up
after you have done a software upgrade. This is good because, should you forget to save your
database, it gives you an opportunity to reconsider your actions before the DXP erases the current
database.

5. Replace the front panel on the main cabinet.

Upgrading DXP System Software – 21
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Installing the RAM Card and Software Card in the DXP

CAUTION

Electronic circuit boards are susceptible to damage caused by electrostatic
discharge and must be handled accordingly. Refer to the Comdial publication
IMI01-005, Handling of Electrostatically Sensitive Components, for general
information. Specific handling precautions are also included in this installation
instruction. The expanded memory card (DXRAM-EXPC) and the system software
memory card (DXPSW-DLRC) are supplied in static protection bags. Do not open a
static protection bag before installation time.

Installing the Cards in the DXP

Turn off the power to the DXP, and install both the RAM card (DXRAM-EXPC) and the

software memory card (DXPSW-DLRC) on the central processor unit (DXCPU-68KJ)

circuit board of the DXP digital communications system.

1. Loosen the retaining hardware and remove the front panel from the DXP main
cabinet.

2. Turn off the AC power switch, and disconnect the AC power cord from the AC outlet.
Disconnect the cable of the optional battery backup from the main cabinet power
supply.

3. Place a conductive mat in front of the cabinet area and ground the mat to a good
earth ground (the third wire ground of the AC power line is an acceptable grounding
point). The grounded conductive mat will provide a safe static electric discharge path.

4. Install the static discharge wrist strap (supplied with the main cabinet) on your bare
wrist; adjust it for a snug fit. Be sure that the strap is touching bare skin and is not
isolated by clothing. Connect the wrist strap cord between the wrist strap and an AC
or earth ground.

Note: With the common equipment in the installed position, the ground lug on the side of the cabinet is an
appropriate grounding point since it should have a heavy ground wire connected between it and a
good earth ground.

5. Find the DXCPU-68K circuit board, loosen the retaining screws, remove it from the
DXP main cabinet, place it in a static protection bag, and transport it to the
static-safe work area.

6. At the static-safe work area, with your wrist strap in place, remove the DXCPU-68K
circuit board, the new DXRAM-EXPC expansion memory card and the new
DXPSW-DLRC software memory card from their static protection bags.

7. Refer to illustration on page 21 and remove the currently installed memory cards
from the DXCPU-68K board.

8. Orient the board and the new memory cards as shown in the illustration, and attach
them with the supplied hardware. (The screws and standoffs between the cards are
essential to ensure proper grounding.)

9. Place the old memory cards in static protection bags and save them for later return
for credit. Place the DXCPU-68K board and newly installed memory cards into a
static protection bag and transport back to the DXP main cabinet.
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10.With your wrist strap properly grounded, remove the DXCPU-68K circuit board from
the static protection bag. Orient it with the top and bottom guides in the main
cabinet board cage, and press it in firmly until the board edge connector properly
mates with the backplane connector.

CAUTION

When pressing the DXCPU-68K board into place, press it only at the extractor
level locations. If you apply pressure at other locations, you may damage the
board assembly.

11.Make a final inspection to ensure that the DXCPU-68K circuit board is in the correct
slot, oriented correctly and mated properly, then install and tighten the supplied
screws to secure it to the board cage.
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#4 Lockwasher
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Translating an
Earlier Database to
a CCB Database

Translating a Non-CCB Database

To use VMMI on the DXP system, you must upgrade the DXP software to at least release

10A (or to whatever software revision that is current). Further, to preserve your existing

database you must convert it though the PCMMI database programming software that is

at software release 9x. You can use the 9A revision of the PCMMI programming software

to up-load your current DXP database and then download it to a data storage area–such

as your computer’s hard drive–as a revision 9A database.* You must then use the VMMI

feature to translate this stored 9A data into at least a 10A database. Use this procedure to

translate a database, which you have first converted to be compatible to software release

9x, to be compatible with a common code base software release 10A or later.

1. On the File menu, click Open As.

2. On the Open Database File dialog box, select the database that you wish to open, and
then click Open.

A prompt asks you to confirm the choice, click OK to proceed.

3. Type a new file location where the translated database can reside.

4. Select the destination platform type and master clear mode for the system and then
click Next.

5. Select the feature set.

Depending on the type of platform selected the dialog box display supports types. If this
option displays, select any combination of supports, and then click Finish. The Select
Board Type dialog box appears.

6. Use the Select Board Type dialog box to describe the board configuration of the
database that you are translating.

a. For reference before upgrading the software to 10A or later, make a record of the
DXP’s physical board configuration.
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b. Use the board record information to answer the prompts on the Select Board Type
dialog box. The prompts first ask for all installed station board beginning with the
DXP’s leftmost universal slot in the main cabinet. The prompts then ask for all
installed line boards beginning with the DXP’s leftmost line slot in the main
cabinet. When a slot in the original DXP contains an auxiliary board, select the

No Board response. The prompt asks for a station board but a line board

occupies that slot in the original DXP, select the No Board response. When the
prompt asks for a line board but a station board occupies that slot in the original

DXP, select the No Board response. When you finish listing the board
configuration, OK your selections.

Note: Under BOARD CONFIGURATION | CABINET VIEW, the graphic shows the boards installed in the
arrangement that you specified and leave a blank slot for any place that you answered a station or line
board prompt with a No Board response.

c. A prompt asks that you confirm that conversion has taken place by clicking OK.

7. Click Open As.

8. Select the file name that you specified in step 4 and OK your selection.

9. Type the destination revision and destination platform for the translated database
and OK your specification. Database translation now occurs.

10.On the File menu, click Save.

11.Check the translated results, and under BOARD CONFIGURATION | CABINET
VIEW, use your mouse to move the board images to match your plan for the
upgraded system, Remember, you must physically move the boards in the common
equipment cabinet to match the arrangement that you set with the program.

Translating the DXP and DXP Plus Database

You can use the VMMI to translate the database residing in a DXP to a format that is

compatible with a 10A or later software release. Before you can translate the database,

you must convert it to a 9A software release level.

1. Select Start | Programs | Vmmi | VMMI.

2. On the File menu, click Open as.

The system default conditions cause the program to search for all *. files in the VMMI

directory; however, you may need to type the path location and DOS file name of the DXP

database that you wish to translate.

3. On the Open Database File dialog box, select the database for translation, and NEXT.

4. After translation is complete, on the File menu, click Save As. Assign your database a
new name.
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6. Use the Select Board Type dialog box to describe the board configuration of the
database that you are translating.

a. Make a record of the physical board configuration by entering product codes in
the following table.

DXP Main
Cabinet

Universal
Slot

Product
Code of
Installed

Board

Station
Number
of Slot

Line
Number
of Slot

DXP
Expansion

Cabinet
Universal

Slot

Product
Code of
Installed

Board

Station
Number
of Slot

Line
Number
of Slot

UNV1/AUX 1-16 UNV6 81-96 121-128

UNV2/AUX 17-32 UNV7 97-112 113-120

UNV3 33-48 UNV8 113-128 105-112

UNV4 49-54 UNV10 129-144 97-104

UNV5 55-80 UNV11 145-160 89-96

LINE1 25-32 UNV12 161-176 81-88

LINE2 17-24 177-192 73-80

LINE3 9-16

LINE4 1-8

b. Using your charted information, answer the prompts on the Select Board Type
window. The prompts first ask for all installed station boards beginning with the
DXP’s leftmost universal slot in the main cabinet. The prompts then ask for all
installed line boards beginning with the DXP’s leftmost slot in the main cabinet.

When a slot in the original DXP contains an auxiliary board, select the No Board
response. When the prompts ask for a station board but a line board occupies

that slot in the original DXP, select the No Board response. When the prompt
asks for a line board but a station board occupies that slot in the original DXP,

select the No Board response. When you finish listing the board configuration,
OK your selections.
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c. The VMMI program presents a screen graphic that depicts the boards installed in
a default arrangement in the main and expansion cabinets of a DXP Plus system.
The default arrangement places station boards in ascending slot order beginning
with slot 1 in the main cabinet; it places line boards in descending slot order
beginning with slot thirty in the lower expansion cabinet. The VMMI program
leaves a blank slot for any place that you answered a station or line board prompt

with a No Board response.

d. Since your system may not include one or both expansions cabinets or you do not
care for the software arranged board layouts, use your mouse to move the board
images to the slots that you would rather that they occupy. Make a record of
these board locations so that you or your installer can physically install the
boards to match your plan.

DXP Plus Upper Expansion
Cabinet Universal Slot

Enter Product Code of Installed Board

10(1-32)/AUX1

11(1-32)/AUX2

12(1-32)

13(1-32)

14(1-32)

15(1-32)

16(1-32)

17(1-32)

18(1-32)

19(1-32)

20(1-32)
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DXP Plus Upper Main Cabinet
Universal Slot

Enter Product Code of Installed Board

1(1-32)/AUX

2(1-32)

3(1-32)

4(1-32)

5(1-32)

6(1-32)

7(1-32)

8(1-32)

9(1-32)

DXP Plus Lower Expansion Cabinet
Universal Slot

Enter Product Code of Installed Board

21(1-32)/AUX1

22(1-32)/AUX2

23(1-32)

24(1-32)

25(1-32)

26(1-32)

27(1-32)

28(1-32)

29(1-32)

30(1-32)

7. From the File menu, select Save.

The computer saves the translated database to the file that you named in step 5.
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Programming with
VMMI

Starting Application

To start the application from Windows Desktop select Start | Programs | Vmmi | VMMI.

The VMMI window appears. The VMMI window contains the menu bar and the Comdial

VMMI logo.
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Locating and Using the VMMI Menu and Tool Bars

Understanding the Menu Bar

The menu bar is located at the top of your window and contains various options. When

you point to a menu title with the mouse and click once, the menu drops down. Clicking

once on the desired menu option executes that command. Commands with ellipses (...)

after them prompt you for additional information. The following menu bar options are

available: File Edit View Programming Switch Help. Paragraphs that follow in this

chapter provide detailed descriptions of each of these menu bar options

Note: Using keyboard shortcuts can also execute most commands. For example, you can open the
Programming menu by holding down the ALT key and pressing the R key.
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Understanding the VMMI Toolbar

The VMMI toolbar contains buttons that help you quickly open, save, and apply. The

following list describes each button on the VMMI toolbar.

• New – Allows you to start a new database.

• Open – Allows you to open an existing database.

• Save – Allows you to save a database with all of your changes.

• Cut – Allows you to remove a selected item from one area and place it on the

clipboard.

• Copy – Allows you to copy a selected item and place it on the clipboard.

• Paste – Allows you to insert an item from the clipboard into the selected area of the

application.

• Print – Allows you to print selected items from the Print Dialog box.

• About – Launches the VMMI Database Programming Help file.

• Apply – Allows you to make changes in the application.

• Undo – Allows you to undo your last action.

• Add Items – Allows you to add items in the database.

• Remove Items – Allows you to remove items from the database.

• Next in Database – Allows you to display the next item in a database.

• Previous in Database – Allows you to display the previous item in a database.

• Connect – Allows you to connect to the switch.

• Disconnect – Allows you to disconnect from the switch.

• Items – Displays the station(s) or other database items.

• Browse – Allows you to select the station(s) to display in the Item box
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Defining the File Menu

The File menu contains standard File options (for example, New, Open, and Save) In

addition, the File menu contains the Master Clear and Print options. The New, Master

Clear and Print options are detailed beginning on

page 88.

• New – Creates a new database. Refer to page 88

for detailed instructions.

• Open – Opens an existing database.

• Open As – Translates an existing database.

• Close – Closes the current database.

• Save – Saves the current database.

• Save As – Saves the current database under a

new name.

• Master Clear – Returns the entire system to the

selected default operation parameters, clears all

stored speed dial numbers, and clears any other

custom programming.

• Print – Prints record of selected programming

area.

• Print Preview – Provides a preview of the selected

programming area.

• Print Setup – Sets parameters for a printer.

• Exit – Exits the VMMI application.
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Defining the Edit Menu

The Edit menu contains options that allow you to apply your changes, undo recent

changes made, add an item, remove an item, block assign extensions, copy items, set

defaults and find (on this page) items. The instructions for setting block assign

extensions, defaults and using the find (on this page) can be found beginning on page 90.

• Apply – Applies the changes made.

• Undo – Reverse the last applied change.

• Add Item – Allows you to add items (for

example, Pilot Numbers, Group Intercom

Extension, and Account Codes). This option is

only available when the software has

information available for adding.

• Remove Item – Allows you to remove items (for

example, Pilot Numbers, Group Intercom

Extensions, and Account Codes). This option is

only available when the software has

information available for removal.

• Block Assign Extensions – Lets you assign

blocks of extension numbers to specific station

ports.

• Copy Item – Allows you to copy items (for

example, Pilot Numbers, Group Intercom

Extension, and Account Codes). This option is

only available when the software has

information available for copying.

• Defaults – Assigns default parameters for specified features.

• Find (on this page) – Provides search capability only on the active page.

Defining the View Menu

The View menu contains options that allow you to view the next item, previous item,

selected item, programming grid, toolbar, and status

bar. Toggle the toolbar or status bar to display or

hide the bar.

• Next Item – Displays the next item.

• Previous Item – Displays the previous item.

• Select Item – Displays the selected item.

• Programming Grid – Displays the programming

grid.

• Toolbar – Displays or hides the toolbar.

• Status Bar – Displays or hides the status bar.
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Defining the Programming Menu

The Programming menu contains options that allow you to program the configuration for

VMMI. The menu options that contain an arrow beside them have an additional

drop-down menu. The Programming Menu options are described in detail on page 39.

• System... – Displays a sub-menu that allows you to

set general parameters for the entire system.

• Networking – Displays a sub-menu that allows you

to set parameters for linking two or more systems

together providing unified extensions and feature

access across the network system.

• Stations – Displays the Database Programming:

Stations window.

• Station Menus – Displays a sub-menu that allows

you to customize individual stations and groups of

stations to have the particular features needed by

different users.

• Lines – Displays the Database Programming: Lines

window.

• Line Menu... – Displays a sub-menu that allows

you to define the lines connected to the switch.

• Group Intercoms – Displays the Database

Programming: Group Intercom window. This

window allows you to specify the system intercom

numbering and provide information and options

about each of the group intercom numbers.

• SMDA / SMDR... – Displays a sub-menu that

provides call activity records for each station in the

system.

• Toll / ARS... – Displays a sub-menu that allows you to program different dialing needs

by allowing users to dial certain numbers yet restricting them from others.

• Peripherals... – Displays a sub-menu that allows you to program the peripheral

equipment.

• Board Configuration – Displays the Database Programming: Board Configuration

window. This window allows you to specify which boards are installed in the main and

expansion cabinets.

• Cabinet View – Displays the Database Programming: Cabinet View window. This

window allows you to specify which boards are installed in the main and expansion

cabinets.

• Boards Menu – Displays a sub-menu that allows you to program the boards that you

specified in the configuration.
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Defining the Switch Menu

The Switch menu contains options that allow you to connect and disconnect to the

switch, archive and restore databases, and change system passwords. The Switch Menu

options are described in detail on page 83.

Note: You must be online with the communication system before you can select any of the menu options other
than Connect.

• Connect to – Connects VMMI to a remote

system.

• Disconnect – Disconnects VMMI from the

system.

• Archive Database – Allows you to

download the database from the remote

system to a PC.

• Restore Database – Allows you to upload

a stored database from a PC to the remote

system.

• Change System Password – Allows you to

change the password.

• Change System Time – Allows you to

change / set the system clock.

• Reset System – Allows you to reset your

digital communications system.

• System Key Wizard – Allows you to view

or modify the system software key.

• System Software Upgrade – Allows you to

upgrade your system software. Displays a

warning box prior to upgrading the

system software.

• Reset Board(s) – Provides you a means to

remotely reset T1 and E1 line boards.

This remote resetting feature eliminates

travel to a site to merely reset a T1 or E1

board.

• ISDN Card Software Upgrade – Allows you to upgrade the software on the DXPRI board

which installs on the DXPT1 board.

• IP Link Software Upgrade – Allows you to upgrade the software on the Voice over

Internet Protocol (VoIP) board.

• Clear Line Problem Counters – Allows you return all lines to service and clear the

problem counters.

• Modify Number of Speed Dials – Allows you to select the quantity of system speed dial

numbers that will be available for use.

• Modem Data Pipe Mode – (FX System feature only.) Allows you to access either the

telephony or computer aspects of the FX system for support or maintenance purposes.
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Defining the Help Menu

The Help menu contains options that allow you to display on-line help, system

information, and VMMI information. The Help Menu options are described in detail on

page 92.

• Contents – Displays the on-line help

system.

• Tip of the Day – Provides various tips on

VMMI operation. You can turn this option

off if you wish.

• About System... – Information displayed

varies depending if you are programming

on-line or off-line. Displays what type of

system you are using either on-line or

offline. Gives you the system release

number and the system feature set. If you

are programming on-line it will also

provide you with the system network

version and system memory information.

• About VMMI... – Displays the VMMI release

number, latest supported feature set,

VMMI build number, and copyright

information.
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Understanding Programming Menu Options

The System menu is where you select the options to set the parameters for VMMI. System

programming involves features that affect the operation of every telephone in the system.

Some parameters that you set with the system programming menu require that you take

further programming action at the line or station level to engage, disengage, or customize

a feature for an individual line, station or an entire station class of service. The System

menu is under the Programming option on the menu bar.

System Menu

1. On the Programming menu, click System.

LCD Messages

The LCD Messages window is where station users set messages at stations with LCD.

Note: This feature is enabled only in station Class of Service 32 by default. If you want this feature in other
classes of service, you must enable Messaging.

1. On the System menu, click LCD Messages.

2. Highlight the LCD Message line to modify.

3. In the Feature Value box, type the message
to display.

4. Continue steps 2, 3, and 4 until all the
messages are entered. Allows for a total of
30 messages.

5. In the Edit menu, click Apply, or click on the
Apply symbol on the toolbar.
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Serial Ports

The Serial Ports window is where you set serial interfaces that you use for connecting

applicable data devices to the communications system.

1. On the System menu, click Serial Ports.

2. In the Item(s) box on the tool bar, select the serial port to modify (use the browse
button if needed).

3. Highlight the serial ports feature to modify.

4. In the Feature Value box, type the first character value or click on the drop down arrow
and select from the choices listed, or if available, click the Browse button to select
from a list.

5. In the Edit menu, click Apply, or click on the Apply symbol on the toolbar.

SOHVA (Subdued Off-Hook Voice Announce) Table

The SOHVA Table is where you set the option to allow a telephone user to break in on any

call in progress at another extension

(off-hook) without being heard by the

outside party. You can use the Default

button to set default values.

1. On the System menu, click SOHVA
Table.

2. Click the Clear button to clear the
matrix.

3. In the matrix, click on the box
where the desired Transmit and
Receive Groups intersect or click
May SOHVA To Groups: (Transmit

Group) or May Be SOHVAed By

Groups: (Receive group) and the corresponding boxes will be filled in.

5. In the Group list box, click the group taking action.

6. In the Group list box, click the group receiving the action.

7. In the Edit menu, click Apply, or click on the Apply symbol on the toolbar.

Note: You must first form the SOHVA Groups using the SOHVA Table and then you must assign the individual
station to the group.
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Station Block Table

The Station Block Table is where you create different groups of stations that cannot make

intercom calls to one another if they are not in the same station group. You can use the

Default button to set default values.

1. On the System menu, click Station Block Table.

2. Click the Clear button to clear the matrix.

3. In the matrix, click on the box where the desired Group Blocked and Block Group

intersects or click the desired box in the May Block Groups or May Be Blocked By

Groups and the corresponding boxes will be filled in.

5. In the Group list box, click the block group.

6. In the Group list box, click the group blocked.

7. In the Edit menu, click Apply, or click on the Apply symbol on the toolbar.
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Speed Dials

The Speed Dials window is where you set speed dial numbers for the system. The system

provides 500 system speed dial numbers by default, or fifty groups of ten numbers per

group. When connected to the switch you can modify the speed dial to 1000, or fifty

groups of twenty numbers per group.

Note: When you increase the number of system speed dials you will lose all previously programmed speed dial
numbers. Once you created the speed dial groups, you must assign none, one, or a range of groups to
each station class of service.

1. On the System menu, click Speed Dials.

2. Highlight the line to modify.

3. In the Preselect Type box, click the drop down arrow to display available line options.

4. Click the desired option.

a. If you selected Line in the Preselect Type box, the Line Number box becomes
active.

In the Line Number box, type the line number or click on the Browse button.

b. If you selected Line Group in the Preselect Type box, the Line Group box becomes
active.
In the Line Group box, type the line group number or click on the drop down arrow to
display available options.

c. If you selected Prime/Last, Itcm, or ARS, click on the line number and enter the
telephone number associated with that line.

5. In the Number to Dial box, type the speed dial number (up to 32-digits).

6. In the Name box, type the speed dial name (up to 7-digits).

7. In the Edit menu, click Apply, or click on the Apply symbol on the toolbar.
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Timing

The Timing window is where you set the timing parameters for the entire system (for

example, time-out periods, recall limits, and time duration for calling features).

1. On the System menu, click Timing.

2. Highlight the timing feature to modify.

3. In the Feature Value box, type the first character

value, or if available, click the drop down arrow button
to select from a list.

4. In the Edit menu, click Apply, or click on the Apply
symbol on the toolbar.

System Parameters

The System Parameters window is where the system user programs options (for example,

set majority of operating limits for entire system or to change button designation order).

1. On the System menu, click System Parameters.

2. Highlight the feature to modify.

3. In the Feature Value box, type the first
character value, click the drop down arrow, or if
available, click the Browse button to select from a
list.

4. In the Edit menu, click Apply, or click on the
Apply symbol on the toolbar.

Paging Zones

The Paging Zones window is where you arrange

stations to transmit and receive voice

announcements, to and from a particular group of

stations or to all stations in the system.

1. On the System menu, click Paging
Zones.

2. In the item(s) box on the tool bar, select
the paging zone to edit.

3. Highlight the feature to modify.

4. In the Feature Value box, type the

station value, or click the drop down
arrow button to select from a list or if

available, click the Browse button to add / remove the desired options.

5. In the Edit menu, click Apply, or click on the Apply symbol on the toolbar.
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Relays

The Relays window is where you set relays for enhanced ringing and ringing assignments

for specific lines.

• Ringer Assignment - You can assign one or more of the four relays, which are located

in the equipment cabinet, to tract the ring signal of any or all line ports that you

assign to the relays. You can arrange for the tracked ringing to be during the direct,

delayed, day 1, day 2, or night ringing modes.

• Enhanced Ringing - You can set relay tracking of system enhanced ringing.

Note: The times and days selected will supercede any standard enhanced ringing times.

1. On the System menu, click Relays.

2. In the item(s) box on the tool bar, select the
relay to edit.

2. Highlight the feature to modify.

3. In the Feature Value box, type the value,

or if available, click the Browse button to add /
remove the desired options.

4. In the Edit menu, click Apply, or click on

the Apply symbol on the toolbar.

External Pagers

The External Pagers window is where you set tracking of an external wide area paging

device to the time that you set in system enhanced ringing (see page 47).

1. On the System menu, click External
Pagers.

2. Highlight the feature to modify.

3. In the Feature Value box, type the value,

or if available, click the Browse button to add /
remove the desired options.

4. In the Edit menu, click Apply, or click on
the Apply symbol on the toolbar.
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Feature Numbers

The Feature Numbers window is where you set the dialing codes for user features. These

codes are flexible so that you can renumber them.

CAUTION

If a number conflict exists, the system prompts you. You must remove the conflict
before you can make the assignment. Be sure that doing this will not disturb
other programmed features that depend upon the removed number.

1. On the System menu, click Feature Numbers.

2. Highlight the feature to modify.

3. In the Current box, type the new value.
The default value displays in the Default box.

4. In the Edit menu, click Apply, or click on the Apply
symbol on the toolbar.

T1 / E1 Alarms

The T1 / E1 Alarms window is where you choose the

status and alarm alerting parameters.

1. On the System menu, click T1 / E1 Alarms.

2. Highlight the feature to modify.

3. In the Feature Value box, type the value, or
if available, click the drop down arrow to
select from a list.

4. In the Edit menu, click Apply, or click on the
Apply symbol on the toolbar.

Note: E1 is a European version of the North American
telephony format.
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Major Alarms

The Major Alarms window is where you program the system to activate an external,

customer-supplied audible or visual alarm to alert the attendant of an alarm condition.

The system attendant can turn the alarm off from any specified station by dialing a

feature code.

1. On the System menu, click
Major Alarms.

2. Highlight the feature to
modify.

3. In the Feature Value box,

type the value, or if
available, click the drop down
arrow to select from a list.

4. In the Edit menu, click
Apply, or click on the Apply
symbol on the toolbar.

Centrex Message Waiting

The Centrex Message Waiting window is where you set message waiting and Caller ID

interfaces, for the common equipment cabinets.

1. On the System menu, click Centrex Message Waiting.

2. Highlight the line to modify.

3. In the Preselect Type box, click the drop down arrow to display available line options.

4. Click the desired option.

a. If you selected Line in the Preselect Type
box, the Line Number box becomes active.

In the Line Number box, type the line

number or click on the Browse button.

b. If you selected Line Group in the Preselect
Type box, the Line Group box becomes
active.
In the Line Group box, type the line group
number or click on the drop down arrow to
display available options.

c. If you selected Prime/Last, Itcm, or ARS, click on the number to dial box and
enter the telephone number associated with that line.

5. Type in the Number to Dial no matter what line type is chosen.

6. Type in the Name associated with the number to dial.

7. In the Edit menu, click Apply, or click on the Apply symbol on the toolbar.
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Enhanced Ringing Options

The Enhanced Ringing Options window is where you program the versatile set of ringing

choices by providing alternate ringing assignments on specific programmed days of the

week or specific programmed holidays.

1. On the System menu, click Enhanced
Ringing Options.

2. Highlight the day of the week that you are
going to set the beginning and ending times.

3. In the Feature Name box, type in the first
character value to either enable or disable, or
click the drop down arrow to display the
available options.

4. Click Enabled.

5. Highlight the Day 1 Begin Time to set the
beginning time.

6. In the Feature Value box, highlight none and type the beginning time.

7. Highlight the Day 1 End Time to set the ending time.

8. In the Feature Value box, highlight none and type in the ending time.

9. You can repeat steps 5 - 8 to set the time for Day 2.

10.In the Edit menu, click Apply, or click on the Apply symbol on the toolbar.

Enhanced Ringing Holidays

The Enhanced Ringing Holidays window is where you program

the month and day for up to thirty holidays.

Note: Set the beginning and ending time for under the Enhanced Ringing
Options.

1. On the System menu, click Enhanced Ringing Holidays.

2. Highlight the item number to assign a holiday.

3. In the Month box, type the first character of the desired
month or click the drop down arrow to select from a list.

4. In the Day box, type the day of the month, or click Browse

and select from a list.

5. In the Edit menu, click Apply, or click on the Apply symbol on
the toolbar.
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Understanding Networking Menu Options

The Networking menu contains the options that allow two or more systems to share

features and extension access. The systems participating in the network are called nodes.

Each network contains a special node called the hub. The hub controls the networking

features of all other nodes. Each node is granted access to particular extensions through

the hub database. A database may either be enabled or disabled for networking. A

database is enabled for networking as either a hub, node, or QSIG.node. There may be

only one hub in the network.

Networking Menu

1. On the Programming menu, click Networking.

Network Properties

The Network Properties window is where you enable or disable the hub, node or QSIG

node operation.

1. On the Networking menu, click
Network Properties.

2. Highlight the feature to apply.

3. In the Feature Value box, click the
drop down arrow, or if available, click the
Browse button to select from a list.

4. In the Edit menu, click Apply, or click on the Apply symbol on the toolbar.

Node Configuration

The Node Configuration window is a Hub system only screen where you define the hub

and the nodes that the network will use.

1. On the Networking menu, click Node
Configuration.

2. In the item(s) box on the tool bar, select the
node to edit.

2. Highlight the feature to apply.

3. In the Feature Value box, type the value,
click the drop down arrow, or if available, click the
Browse button to select from a list.

4. In the Edit menu, click Apply, or click on the Apply symbol on the toolbar.
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Network Links

The Network Links window is Hub system only window where you program the physical

links between the hub and the nodes.

1. On the Networking menu, click Network
Links.

2. Highlight a row to assign links to the node
that appears in the row.

3. In the Link Slots box, type the slot of
numbers or click Browse to select from a
list.

4. In the Edit menu, click Apply, or click on
the Apply symbol on the toolbar.

Add Network Extension

The Add Network Extension window is a Hub system only window where you provide

intercom numbers for validation purposes and either assign these numbers to nodes or

remove numbers that you have previously assigned.

Note: This window only maps the allowed numbers. You must use intercom number programming at the hub
and each node to assign station names and port
numbers to intercom numbers. Further, to insure that
the network feature operates properly, you must
assign unique extension numbers at each system.

1. On the Networking menu, click Add Network
Extension.

2. Highlight the Node or Hub to assign.

3. Under Add Network Node Extension, in the

Starting Extension box, type the starting

extension number.

4. Under Add Network Node Extension, in the

Ending Extension box, type the ending

extension number.

5. Click the Add Extension(s) button and the
numbers will appear in the Currently
Assigned box.

6. In the Edit menu, click Apply, or click on the Apply symbol on the toolbar.
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Remove Network Extensions

The Remove Network Extensions window is where you remove intercom numbers from a

node.

1. On the Networking menu, click Remove Network Extension.

2. In the Currently Assigned box, highlight the numbers to remove.

3. Click the Remove Extensions button.

4. In the Edit menu, click Apply, or click on the Apply symbol on the toolbar.
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Understanding the Stations Window

The Stations window is where you customize the features of individual telephone stations

to fit special user needs.

1. On the Programming menu, click Stations.

2. Highlight the station(s) to assign.

3. In the item(s) box on the tool bar, select the feature to edit.

4. In the Feature Value box, type the value, click the drop down arrow, or the Button Map
button, or if available, click the Browse button to select from a list.

4. In the Edit menu, click Apply, or click on the Apply symbol on the toolbar.

Understanding Station Menu Options

The Station menu contains the options to customize class of service from station hunt

groups, and assign authorization codes.

Station Menu

1. On the Programming menu, click Station Menu.
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Station Hunting

The Station Hunting window is where you configure a system feature, allowing any of

several stations to service a call.

1. On the Station menu, click Station Hunting.

2. On the toolbar, click the Add Items (+) icon. Enter a valid Pilot
Number on the Hunt Group Add screen. Click OK.

3. In the item(s) box on the tool bar, enter the pilot number of
the existing hunt group.

4. Highlight the feature to apply.

5. In the Feature Value box, type the value, click the drop down
arrow, or if available, click the Browse button to select from a list.

6. In the Edit menu, click Apply, or click on the Apply symbol on the toolbar.
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Class of Service

The Class of Service window is where you assign a group of preprogrammed Class of

Service station features to a station. The system makes up to thirty-two different classes

of service available, and you can program the feature values differently in each.

1. On the Station menu, click Class of Service.

2. In the item(s) box on the tool bar, select the class of service to edit.

3. Highlight the COS feature to apply.

4. In the Feature Value box, type the value, click the drop down arrow, or if available, click
the Browse button to select from a list.

5. In the Edit menu, click Apply, or click on the Apply symbol on the toolbar.
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Authorization Codes

The Authorization Codes window is where you provide system users the mobility to use

their class of service on any telephone in the system.

1. On the Station menu, click Authorization Codes.

2. In the Authorization Codes menu, click edit, then
select Add Item or click on the Add Items (+) button on
the toolbar.

3. In the Authorization Code box, type the

authorization code.

4. Click the Browse button to display a list of extensions.

5. Select the extension number from the list, then click
OK.

6. In the Edit menu, click Apply, or click on the Apply symbol on the toolbar.
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Understanding the Lines Window

The Lines window allows you to select different operating parameters for each connected

line. The digital communications system can use several types of lines, and each line type

offers different programming options. Line programming allows you to select different

operating parameters for each connected line.

1. On the Programming menu, click Lines.

2. In the Item(s) box type in the line number(s) to be changed or click on the Browse
button to add / remove lines from the list, then click OK. Line(s) selected display in
the Item box.

3. Highlight the feature to apply.

4. In the Feature Value box, type the value, click the drop down arrow, or if available, click
the Browse button to select from a list.

5. In the Edit menu, click Apply, or click on the Apply symbol on the toolbar.

Understanding Line Menu Options

This Line menu contains the options that allow you to customize each telephone line to fit

the needs of its user.

Note: DID lines are incoming only and have numbers assigned by the central office. These numbers are
translated into intercoms based on the DID Block Translation Table.

Note: Outside callers may call directly into the system. DISA callers dial an authorization code allowing them to
use the system’s features normally available only to inside callers.

Line Menu

1. On the Programming menu, click Line Menu.
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Line Groups

The Line Groups window is where you group similar type line ports together for dial-up

access. There is a maximum of sixteen different line groups available. You can put all

lines in one group or you can divide the total line capacity across all sixteen groups.

1. On the Line menu, click Line Groups.

2. Highlight the first blank line.

3. In the Group Name box, type the name for the group. Maximum of 7-characters.

4. Click Browse to add / remove group members in the Group Members box.

5. In the ARS Access box, click the drop down arrow to select from a list of options.

6. In the Network Specific Facility box, click the drop down arrow to select from a list of
options.

7. In the Hunting box, click the drop down arrow to select from a list of options.

8. Click the Network Line Group box, click the drop down arrow to select from a list of
options.

9. In the Edit menu, click Apply, or click on the Apply symbol on the toolbar.

DID Block Options

The DID Block Options’ window is where you set the values for incoming Central Office

(CO) calls to reach internal intercom extensions by direct dialing.

1. On the Line menu, click DID Block Options.

2. In the Item(s) box type in the line number(s)
to be changed or click on the Browse button
to add / remove lines from the list, then
click OK. Line(s) selected display in the Item
box.

3. Highlight the feature to apply.

3. In the Feature Value box, type the value,
click the drop down arrow, or if available, click the
Browse button to select from a list.

4. In the Edit menu, click Apply, or click on the Apply symbol on the toolbar.
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DID Translation Table

The DID Translation Table is where you initialize a translation table. You must first enter

the string of CO digits that you obtain from the telephone company.

1. On the Line menu, click DID Translation Table.

2. In the DID Translation Table menu, click edit, then select Add Item or click on the Add
Items (+) button on the toolbar to add the range of CO digits purchased.
The DID Add dialog box appears

3. Under the CO Digits, in the From and To boxes, type in the range of numbers you

purchased from the CO.

4. In the Block Number box, click the drop down arrow to select from a list of block numbers.

5. Click the Default Ext button and select the extension numbers from the Extensions
Available for Selection list, click Add, then OK.

6. Click OK on the DID Add dialog box. The DID Translation Table appears. See page 58
for illustration.

7. In the Edit menu, click Apply, or click on the Apply symbol on the toolbar.

Note: You can modify the extension numbers on the DID Translation Table.
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Note: Due to the length of the DID Translation Table the writer split it into three sections for display purposes
only.
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DISA Configuration

The DISA Configuration window is where you program the DISA operation parameters to

meet your site’s requirements by configuring the features.

Note: DISA must be enabled.

1. On the Line menu, click DISA Configuration.

2. Highlight the feature to apply.

3. In the Feature Value box, type the value, click the drop down arrow, or if available, click
the Browse button to select from a list.

4. In the Edit menu, click Apply, or click on the Apply symbol on the toolbar.
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Understanding the Group Intercoms Window

Group intercom numbers are those shared for use by several stations. Anytime someone

calls a group intercom number, all stations assigned to the number rings.

Note: You must use the station programming to enable a station’s ability to answer and originate calls on an
intercom number.

Note: You must also map the button on a telephone at which the group intercom numbers are to appear.

Group Intercoms

1. On the Programming menu, click Group Intercoms.

2. In the Group Intercoms menu, click
edit, then select Add Item or click on the
Add Items (+) button on the toolbar to
add a range of group extensions.

3. In the Starting Extension box, type the
starting extension number.

4. In the Ending Extension box, type the

ending extension number.

5. Click OK.

6. To add a name and full name to the extension
number, highlight the extension number line
to add name and full name.

7. In the Name box, type the display name of the
group. Maximum of 7-characters.

8. In the Full Name box, type the complete

name of the group. Maximum of
20-characters.

9. In the Edit menu, click Apply, or click on the
Apply symbol on the toolbar.

60 – Understanding the Group Intercoms Window

GCA40–182 Programming with VMMI

Adding Group Extensions

Group Intercoms



Understanding SMDA / SMDR Menu Options

The system provides System Message Detail Accounting (SMDA) and System Message

Detail Report (SMDR) information in an ASCII data format for printing on a printer or

exporting into a database for processing. The SMDA report contains account code and call

costing details that the SMDR does not contain.

SMDA / SMDR Menu

1. On the Programming menu, click SMDA / SMDR.

SMDA / SMDR Reports

The SMDA / SMDR Reports window is where you arrange for the SMDR / SMDA

parameters to convey the cost of calls that the stations make, the amount of time that

lines have been on hold at the stations, or the metering pulse totals.

1. On the SMDA / SMDR menu, click SMDA / SMDR Reports.

2. Highlight the feature to apply.

3. In the Feature Value box, type the value, click the drop down arrow, or if available, click
the Browse button to select from a list.

4. In the Edit menu, click Apply, or click on the Apply symbol on the toolbar.
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Account Codes

The Account Codes window is where you identify calls by category, so that VMMI can

record costing by that category.

1. On the SMDA / SMDR menu, click Account Codes.

2. In the Account Codes menu, click edit, then select Add
Item or click on the Add Items (+) button on the toolbar
to add a range of account codes.

3. Under Add Account Codes, in the Start box, type

the starting account number.

4. Under Add Account Codes, the Count box, type the

count number.

5. Click Apply button.

6. Click OK when finished adding account codes.

7. The Account Codes window displays the Account Codes.

Emergency Numbers

The Emergency Numbers window is where you list

the designated emergency numbers. The system

accepts a total of sixteen numbers, and each entry

can have a maximum of sixteen digits.

1. On the SMDA / SMDR menu, click
Emergency Numbers.

2. Highlight the line to modify.

3. In the Emergency Number box, type the

emergency number.

4. In the Alarm Level box, click the drop down
arrow to select from a list of options.

5. In the Edit menu, click Apply, or click on the
Apply symbol on the toolbar.
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UCD Reports

The Uniform Call Distribution (UCD) Reports window provides information about call

activity, which will permit better management of call center operations. You must activate

the UCD Report when creating a New database to use this feature.

1. On the SMDA / SMDR menu, click UCD Reports.

2. In the Feature Name box, click on the drop down arrow, select yes to enable UCD.

3. In the Feature Value box, type the value , click the drop down arrow, or if available,

click the Browse button to select from a list.

4. In the Edit menu, click Apply, or click on the Apply symbol on the toolbar.
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Understanding Toll / ARS Menu Options

The toll restriction feature allows or denies outgoing line calls to selected users over

selected lines. The Automatic Route Selection (ARS) feature allows the system to

automatically route a call over the least-costly line group available to that station.

Toll / ARS Menu

1. On the Programming menu, click Toll / ARS.

Restriction Tables

The Restriction Tables provide for not only toll restriction but also automatic route

selection.

1. On the Toll / ARS menu, click Restriction Tables.

2. Highlight the item to modify.

3. In the Restriction Level box, type the first character value, or click the drop down arrow
to select from a list of options.

4. In the Exception Number box, type the first character value, or click the drop down
arrow to select from a list of options.

5. In the Route Table box, click the drop down arrow to select from a list of options.

6. In the Number to Restrict

box, type the number to

restrict. Maximum
16-digits including 0-9, #,
*, and wildcard symbol @.

7. In the Toll Groups box, type

the toll group number.

8. In the Edit menu, click
Apply, or click on the Apply
symbol on the toolbar.
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Route Tables

There are thirty-two route tables. Each route table has six routes.

Note: Because the ARS feature interacts with the toll restriction feature, you must assign a route table (1-32) to
the number that you entered in the toll restriction table before the system can do ARS.

1. On the Toll / ARS menu, click Route Tables.

2. Highlight the line to modify.

3. In the Line Group box, click the drop
down arrow to select from a list of
options.

4. In the Route Access box, click the drop
down arrow to select from a list of
options.

5. In the Modify Digit Table box, click the

drop down arrow to select from a list of
options.

6. In the Surcharge box, type the

surcharge amount.

7. In the Tier 1 Time box, click the drop
down arrow to select from a list of
options.

8. In the Route Status box, click the drop
down arrow to select from a list of
options.

9. In the Tier 1 Cost box, type the tier 1

cost amount.

10.In the Tier 2 Cost box, type the tier 2 cost amount.

11.In the Edit menu, click Apply, or click on the Apply symbol on the toolbar.
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Modify Digit Table

Each of the six routes in each route table requires a Modify Digit Table number index

entry of one to 128. The system provides 128 different modify digit tables to detail any

modifications that the system needs to do to the user-dialed number. The need for

modification is determined by the type of lines that you include in the line group for the

route. If a line group requires that the dialed number be in a specific format, you must set

up an appropriate Modify Digit Table to create this format.

Note: Numerical sequence of the digits to be added (valid digits are zero to nine, * and # and the pause p
digit) in a digit string.

Note: Number of digits to be deleted from the dialed number (this value can be from zero to ten).

Note: When ARS modifies the dialed number, it first deletes from the beginning of the number and then adds to
the beginning of the number.

1. On the Toll / ARS menu, click Modify Digit Table.

2. Highlight the table to modify.

3. In the Command to Process box, to Add Digits type an I then the digits to add. To Delete
Digits type a D then the digits to delete.

5. In the Edit menu, click Apply, or click on the Apply symbol on the toolbar.
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Understanding Peripherals Menu Options

The Peripherals menu contains the options that allow you to program peripheral

equipment. For example, Caller ID and Paging.

Peripheral Menu

1. On the Programming menu, click Peripherals.

Caller ID

The Caller ID window is where you set the Caller ID options. You can also assign Caller ID

ring no-answer capability to the telephones that are on Caller ID lines.

Note: You must use System Programming to match the data baud rate with that of the Caller ID equipment
(CID08). Use Line Programming to enable the Caller ID lines and use Station Programming to assign
the lines to ring on the telephones.

1. On the Peripherals menu, click Caller
ID.

2. Highlight the Caller ID Options feature
to modify.

3. In the Feature Value box, type the value,
or if available, click the drop down arrow
to select from a list of options.

4. In the Edit menu, click Apply, or click on
the Apply symbol on the toolbar.
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Modem Settings

The Modem Settings window is where you set the internal modem parameters.

1. On the Peripherals menu, click Modem Settings.

2. Highlight the modem feature to modify.

3. In the Feature Value box, type the value, click the drop down arrow, or if available, click
the Browse button to select from a list.

4. In the Edit menu, click Apply, or click on the Apply symbol on the toolbar.

PC Attendant

The PC Attendant position is a computerized attendant operating position. In addition to

the fixed keyboard features, you can use button mapping to assign additional features to

the function keys along the top of the keyboard. You can also use button mapping to

assign special buttons to system telephones so that they are compatible with the text

messaging feature available with the PC Attendant. The system accepts four PC

Attendants positions.

1. On the Peripherals menu, click PC
Attendant.

2. In the item(s) box on the tool bar, select the
PC Attendant position to edit.

3. Highlight the PC Att line to modify.

4. In the Feature Value box, type the value,
click the drop down arrow, or if available, click the Browse button to select from a list.

5. Highlight the Button Mapping line.

6. In the Feature Value box, click the Button Map button to display the Button Mapping
window.

7. Place the cursor in the box you wish to modify.

8. Type in the Feature Code.

9. Press Enter on the keyboard.

10.Click Close when finished.

11.In the Edit menu, click Apply, or click on the Apply symbol on the toolbar.

Note: The Button Mapping window graphically displays the DSS / BLF and keypad of the telephone or console
installed at that station.
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Voice / DVA

The Digital Voice Announce device (DVA) is an optional line-powered unit that connects to

a digital station port and plays pre-recorded voice prompts and dialing instructions to

incoming callers on the direct inward system access (DISA) lines.

1. On the Peripherals menu, click Voice / DVA.

2. Highlight the DVA Message to modify.

3. In the Digit Assignments box, click the drop down
arrow and select the digit assignment.

4. Click the Extension button.

5. Select the extension number from the list.

6. Click OK.

7. Click Feature button.

8. Select feature to assign from the list.

9. Click OK.

10.In the Edit menu, click Apply, or click on the Apply
symbol on the toolbar.
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Pager Units

The Pager Units window is where you interface a digital communications system with the

Tracker pagers.

1. On the Peripherals menu, click Pager Units.

2. Highlight the value to modify.

3. In the Name box, type the name if one does not already appear.

4. In the Number box, click the Browse button to select from a list of options.

5. In the Status box, click the drop down arrow to select from a list of options.

6. In the Model box, click the drop down arrow to select from a list.

7. In the Base Station box, click the drop down arrow to select from a list of options.

8. In the Edit menu, click Apply, or click on the Apply symbol on the toolbar.

Pager Base Stations

You can connect Tracker base stations to the system directly through a serial data port or

indirectly through a PC attendant position.

1. On the Peripherals menu, click Pager Base Stations.

2. Highlight the value to modify.

3. In the Base Station Serial Port box, click the drop down arrow to select from a list of
options.

4. In the Base Station Status box, click the drop down arrow to select from a list of
options.

5. In the Remotely Installed On box, click the drop down arrow to select from a list of
options.

6. In the Edit menu, click Apply, or click on the Apply symbol on the toolbar.
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Voice Mail Extension Table

The Voice Mail Extension Table is where you identify the station intercom number of each

voice mail connection and link these numbers together to form a circular hunt group for

call-handling purposes.

Note: To make the LCD readouts at the system telephones more descriptive during call transfers, use the
intercom name feature found on the station programming general features menu to assign a descriptive
name to the personal intercom numbers.

1. On the Peripherals menu, click Voice Mail Extension Table.

2. Highlight the Station to modify.

3. In the Voice Mail Extension box, click the Browse button to select from a list of
extension numbers.

4. In the Forward to Extension box, click the Browse button to select from a list of
extension numbers.

5. In the Edit menu, click Apply, or click on the Apply symbol on the toolbar.

Understanding Peripherals Menu Options – 71

Programming with VMMI GCA40–182

Voice Mail Extension Table



Voice Mail Integration Digits

The Voice Mail Integration Digits window is where you choose the digits that the digital

communications system sends to a voice mail system. The system defaults the voice mail

parameters to match the Comdial voice mail system.

1. On the Peripherals menu, click Voice Mail Integration Digits Table.

2. Highlight the value to modify.

3. In the Feature Value box, type the value, click the drop down arrow, or if available, click
the Browse button to select from a list.

4. In the Edit menu, click Apply, or click on the Apply symbol on the toolbar.
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Understanding the Board Configuration Window

The Board Configuration window is where you assign the board type to a particular

cabinet slot.

1. On the Programming menu, click Board Configuration.

2. Highlight the slot to add the board.

3. In the Board Type box, click the drop down arrow button to select from a list of possible
boards.

4. In the Edit menu, click Apply, or click on the Apply symbol on the toolbar.
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Understanding the Cabinet View Window

The Cabinet View window depicts the circuit boards installed in their current

configuration. If you first use the Add Board To Slot to arrange the boards in the system,

this window shows that arrangement. The following instructions are for adding a new

board. To remove or move a board refer to the on-line help file.

1. On the Programming menu, click Cabinet View.

2. Highlight the desired slot.

3. Click Add Board To Slot button. The Choose Board
For Slot # appears.

4. In the Value list box, click a Board Type.

5. Click OK.

6. In the Edit menu, click Apply, or click on the Apply
symbol on the toolbar.

Note: Display the circuits for a specific board, highlight the board and click Show Circuits button.

Understanding Boards Menu Options

The Boards menu contains the options that allow you to set

arrangement, assign the name of station, line port locations

associated with the boards, as well as program the parameters for

the various types of boards.

Boards Menu

1. On the Programming menu, click Board Menu.
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Station Port Locations

The Station Port Locations window lists all the station ports, the intercom assignment of

each port, the installation slot location of each port, and the type of station board that

provides each station port interface. The name and extension can be assigned on this

window.

1. On the menu, click Station Port Locations.

2. Highlight the Station to
modify.

3. In the Name box, type the

name.

4. In the Extension box, type

the extension number.

5. In the Edit menu, click Apply,
or click on the Apply symbol
on the toolbar.

Line Port Locations

The Line Port Locations window lists all the line ports, the name assignment of each port,

the installation slot location of each port, and the type of line board that provides each

line port interface. The name assignment of each port can be assigned on this window.

1. On the menu, click Line Port Locations.

2. Highlight the line to modify.

3. In the Line Name box, type the name.

4. In the Edit menu, click Apply, or click on the Apply
symbol on the toolbar.
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IP Link Boards

The IP Link Boards window allows you to modify the settings for networking between

several Wide Area Network (WAN) Ethernet configurations.

1. On the Board menu, click IP Link Boards.

2. Highlight the feature to modify.

3. In the Feature Value box, type in the new value or if available click on the Browse
button to select from a list.

4. Ind the Edit menu, click Apply, or click on the Apply symbol on the toolbar.
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ISDN PRI Boards

The ISDN PRI Boards window is where you make choices that affect ISDN-PRI service.

When you add a board in a board slot, that slot becomes programmable.

1. On the Board menu, click ISDN PRI Boards.

2. Highlight the value to modify.

3. In the Feature Value box, type the value, click the drop down arrow, or if available, click
the Browse button to select from a list.

4. In the Edit menu, click Apply, or click on the Apply symbol on the toolbar.
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ISDN BRI Interfaces

This feature is for DXP and DXP Plus systems only. It provides a way for subscribers to

get digital service from the service provider for two telephones or a telephone and a data

device over one special pair of wires.

1. On the Boards menu, click ISDN BRI Interfaces.

2. Highlight the Interface value to modify.

3. In each Option box, click the drop down arrow to select from a list of options.

4. In the Edit menu, click Apply, or click on the Apply symbol on the toolbar.
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IST Boards

The IST Boards window is where you add application flexibility for industry standard

telephones, the hookswitch and pulse dial timing is programmable for each IST board

that you install in the system.

1. On the Boards menu, click IST Boards.

2. Highlight the value to modify.

3. In the Feature Value box, type the value, or click the drop down arrow to select from a
list of options.

4. In the Edit menu, click Apply, or click on the Apply symbol on the toolbar.

Centrex Msg Wait Boards

The Centrex Msg Wait Boards window is where you filter out the Abbreviated Incoming

Message Wait Ring.

1. On the Boards menu, click Centrex Msg Wait Boards.

2. Highlight the value to modify.

3. In the Feature Value box, type the value, click the drop down arrow, or if available, click
the Browse button to select from a list.

4. In the Edit menu, click Apply, or click on the Apply symbol on the toolbar.
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E1 Boards

The E1 Boards window is where you set the parameters for the E1 Boards.

1. On the Board menu, click E1 Boards.

2. Highlight the value to modify.

3. In the Feature Value box, type the value, or click the drop down arrow to select from a
list of options.

4. In the Edit menu, click Apply, or click on the Apply symbol on the toolbar.

Line Signaling Timers

The Line Signaling Timers window is where you set the parameters for using the Line

Signaling Timers that define DID protocol for line types on the R2-DID line board and

E&M protocol for lines that support E&M signaling on the E1 line board.

1. On the Boards menu, click Line Signaling Timers.

2. Highlight the value to modify.

3. In the Feature Value box, type the value, or click the drop down arrow to select from a
list of options.

4. In the Edit menu, click Apply, or click on the Apply symbol on the toolbar.
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Line Signaling Bits

The Line Signaling Bits window is where you set the parameters for using the Line

Signaling Bits that define DID protocol for line types on the R2-DID line board and E&M

protocol for lines that support E&M signaling on the E1 line board. R2 type analog

signaling is applicable in international applications.

1. On the Board menu, click Line Signaling Bits.

2. In the ABCD Bits box, click on the appropriate Forward and Backward options.

3. Click on the required boxes under Line Signaling Mask.

4. If you are unsure or wish to use preset defaults, click Set Defaults and choose either
Preselect 1 or Preselect 2 under Protocol. Click OK.

5. In the Edit menu, click Apply, or click on the Apply symbol on the toolbar.

Note: This option is for international use only.
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PCTB Board Programming

The PCTB Board Programming window is where you set the parameters for PCTB boards.

PC-based Telecommunications Bus (PCTB) circuit boards are a family of special-purpose

circuit boards. Boards of this type provide conditioned voice paths and signaling methods

that permit various Computer Telephony Interface (CTI) applications to interface between

the PC and telephony portions of the FXS and FXT digital communications systems.

1. On the Board menu, click PCTB Board Programming.

2. Highlight the value to modify.

3. In the Master Clock box, click the drop down arrow to select from a list.

4. In the Bus Speed box, click the drop down arrow to select from a list.

5. In the Edit menu, click Apply, or click on the Apply symbol on the toolbar.

SC Bus Port Programming

The SC Bus interface board connects Computer Telephony Interface (CTI) applications

between circuit boards in the PC and the telephony portion of the FXS and FXT systems

(for example; network, voice, facsimile, speech recognition, video, and so forth to digital

station ports and line ports). The SC Bus board does this through time division

multiplexing (TDM) on the SC Bus.

1. On the Board menu, click SC Bus Port Programming.

2. Highlight the desired feature.

3. In the Port Type box, click the drop down arrow to select from a list of options.

4. In the OAI Link box, click the drop down arrow to select from a list of options.

5. In the Edit menu, click Apply, or click on the Apply symbol on the toolbar.
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Understanding the Switch Menu Options

The Switch Menu contains options that allow you to do several system related operations

(for example, change passwords and archive and restore databases).

Switch Menu

1. On the Switch menu, click Connect To in order to
activate this menu.

Connect To

The Connect To window is where you connect to a remote

system.

1. On the Switch menu, click Connect to.

2. In the User Name box, select
Installer or Administrator.

3. In the Password box, type your

password.

4. Under Dialing Properties, select
Direct Connection.

5. Under Connections Parameters,

type the parameters in the
appropriate boxes.

6. Click Connect.

Disconnect

This window is where you disconnect from the remote system.

1. On the Switch menu, click Disconnect.

Archive Database

Refer to page 11 - Archive a Database.

Restore Database

Refer to page 12 - Restore a Database.
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Change System Password

The Change System Password option is where you change the program entry password for

both the installer and the administrator.

1. On the Switch menu, click Change System
Password.

2. In the User Name box, select Installer or
Administrator.

3. In the Current Password box, type your

current password.

4. In the New Password box, type your new

password.

5. Click OK.

Change System Time

The system clock provides time and date information for display on the LCD and SMDA /

SMDR timing and reporting.

1. On the Switch menu, click Change System Time.

2. In the New Time/Date box, click the drop down arrow
for each option to be changed.

3. Click OK.

Reset System

Times may arise when you need to reset your digital communication system.

1. On the Switch menu, click Reset System.

2. You will receive a message box warning that “You are about to perform a System
Software Reset. This operation will reset the system and disconnect the VMMI. Reset
the system software now?,” click OK.

3. If necessary to reconnect, on the Switch menu, click Connect to.
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System Key Wizard

The System Key wizard allows you to view or modify the system software key. To view

current software key features:

1. On the Switch menu, click System Key
Wizard.

2. Click Next.

3. A box will display showing you, which
software feature set as well as the
standalone features that are enabled.

4. Click Cancel to exit this screen or click Back
to enter a New Software Key.

5. Click on the Provide a New Key box, then
type in the new software key number.

6. Click Next.

7. A box will display showing you, which
software feature set as well as the
standalone features that will be enabled.

8. Click Finish to install the key. The system resets
after the new key is installed.

System Software Upgrade

This option allows you to update your system

software for the DXP, DXP Plus, FXS and FXT Feature Set and Release Number when

necessary. After you click on the System Software Upgrade feature on the Switch menu, you

will see a warning box. Carefully read the message box before proceeding. Detailed

information can be found in the help file under Switch | System Software Upgrade.
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Reset Boards

Provides a means for you to remotely reset T1, T1-PRI, T1-NET and IP Link line boards.

This feature alleviates the need to travel to a remote site simply to reset a board.

1. On the Switch menu, click Reset Boards.

2. A dialog box will pop-up that reads “Please enable board reset first in order to see the
selectable boards here.” Click on the box so that a check mark appears.

3. Select the board you wish to reset from the list, click Reset.

4. The selected board will be reset automatically.

ISDN Card Software Upgrade

Allows you to upgrade the software on the DXPRI card with new software issued by

Comdial.

1. On the Switch menu, click ISDN Card Software
Upgrade.

2. Select the Board Slot for the Firmware Download, click
OK.

3. The following message box will appear as a
reminder, click OK.

4. Locate the *.bin file that you obtained from Comdial and loaded onto your PC.

5. Follow the screen prompts to complete the software upgrade.
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IP Link Software Upgrade

Used to program the software upgrades for the Voice over Internet Protocol (VoIP) board.

While you can perform the VoIP software upgrade remotely through a modem and the IP

network, it is normally programmed while, on site and with your PC directly connected to

the communications system and the Wide Area Network (WAN). For details on

programming the VoIP board, see the help topic entitled, IP Link Boards.

Clear Line Problem Counters

You can mark a line that is not functioning properly as a problem line. You do this by

dialing a feature code or by pressing a preprogrammed button. After you have marked a

problem line for the number of times selected, the system takes the line out of service,

logs the condition for printout and display, and triggers an alarm.

1. On the Switch menu, click Clear Line Problem Counters to reset the counters.

Modify Number of Speed Dials

The Modify Number of Speed Dials allows you to

increase the number of speed dial numbers available

from 500 or 1000. If you are running Release 180 or

later software, then you can set the system for a

maximum of 2000 speed dial numbers. Remember,

though that choosing the larger speed dial capacities

reduces slightly the number of SMDR records that the

system can store.

1. On the Switch menu, click Modify Number of Speed
Dials.

2. An Information message will appear informing you
that “The current system speed dial information will
be lost.,” click OK.

3. Choose the modified number of speed dials
needed, click OK.

4. A Warning message will appear stating that, “The
system will reset if the command is successful. Do
you want to continue?,” click OK.

5. VMMI will update, than you will need to reconnect
to the system.
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Modem Data Pipe Mode

The Modem Data Pipe Mode allows access to the FX system computer from a remote PC,

using , and having that remote PC connected to the FX system.

1. On the Switch menu, click Modify Data Pipe
Mode.

2. Under Status, select On or Off.

3. Click OK.

Understanding File Menu
Options

The File menu contains standard file options (New, Open, Close and Save). In addition,

the File menu contains the Master Clear and Print options.

File Menu

New

The New option affords you the opportunity to create a new

database. VMMI presents you with a dialog box that lets you

specify the data communications system for the new database

that you are creating and the master clear mode you wish the

system to use.

1. On the File menu, click New.

2. In the Platform box, click the drop down arrow to scroll
through the list and highlight your selection.

3. In the Master Clear Mode box, click the drop down arrow to
select from a list of options.

4. Click Next.

5. In the Feature Set box, click on the drop down arrow to
select the correct feature set being used. If you are using
a DXP platform, click Finish.

6. If you are using an FX platform, click in the box next to
the appropriate standalone features, click Finish.
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Master Clear

The Master Clear option returns the entire system to the selected default operating

parameters, clears all stored speed dial numbers, and clears any other custom

programming.

1. On the File menu, click Master Clear.

2. Click the OK button on the Warning
dialog box.

3. In the System Mode box, click the
drop down arrow to select from a list of
options.

4. Click OK. You will then need to
reconnect.

Print

If you have a printer connected to your computer, you can make a hard copy printout of a

programming menu after you make your programming choices.

1. On the File menu, click Print.

2. Select the items to print from the
Unselected Items list.

3. Click Add.

4. Click Print.
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Understanding Edit Menu Options

The Edit menu contains options that allow you to apply your changes, undo recent

changes made, add an item, remove an item, and copy items. In addition it also allows

you to block assign extensions, assign defaults, and find items on the current page.

Edit Menu

Block Assign Extensions

The Block Assign Extensions window lets you assign a block of extension numbers to

specific station ports.

1. On the Edit menu, click
Block Assign Extensions.

2. In the Starting From
Extension box, type the

starting from extension

number.

3. Click the Stations button to
select from a list of
extensions.

4. Click OK.

Defaults

The Defaults window is where you set default parameters for VMMI.

1. On the Edit menu, click Defaults.

2. Select the desired defaults.

3. Click OK.
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Find (on this page)

The Find (on this page) window lets you do a search on the current page only.

1. On the Edit menu, click Find (on this page).

2. Type in the word or words that you are trying to find.

3. In the Direction box, click on the direction you want to search in.

4. Click on the find next button.

5. Repeat steps 2– 4 to start a new search.

6. Click cancel to exit.
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Understanding Help Menu Options

Help Menu

Contents (On-line Help)

A detailed on-line help file accompanies the programming menus. The on-line help files

are accessible from all windows by selecting Help from the menu bar and then selecting

Contents. On-line help files always start at the Main Contents Menu where you can

navigate to the appropriate discussion windows to provide the technical information that

you need. These discussion windows may include green-colored words and phrases that

you can click on to expand the technical discussion or to open other related help files.

Anytime, you click on the Contents button you will return to the Main Contents Menu.

From this menu, you can click on a topic to open any discussion window that you wish to

read.

The discussion windows provide a Search button for your use. When you click on the

Search button, the help file opens a subject menu that you can scroll through as you

search for a particular topic that you need help with. Once you find the topic, you can

click on it to jump directly to its discussion.

Often, the discussion windows provide additional jump paths that allow you to quickly

review related topics. These jump paths may take several forms. They may appear as

separate large windows that you can scroll through as you read the information, or they

may appear as small windows that appear in the middle of the window that you are

currently viewing. When you finish reading the information in the large windows, return

to the starting point by clicking on the Back button as often as necessary. Exit the small

windows by clicking once outside the borders. If you wish completely to leave the help file

when you finish using it, do so by clicking on the Exit button that is on the button bar.

Sometimes you may also want a hard copy of the help file. If so, you can press the Print

button on the help dialog to obtain the printout. You can only print one topic at a time.
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Tip of the Day

Each time this screen is displayed you will

receive a new and useful tip. You have the option

of having a tip show each time you startup

VMMI. If you are looking for a particular subject

area you can keep clicking on the next tip button

to scroll through a variety of tips. When you are

finished simply click on the close button.

About System

This will provide you with information concerning

your current VMMI programming session.

• Type of database being programmed.

• Online or Offline mode.

• System Release Number

• System Feature Set

To exit this screen, click OK.

About VMMI

You will find information on the current VMMI software

release number you are programming in. Also listed is

the latest Comdial supported feature set of software

being run. To exit this screen, click OK.
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This manual has been developed by Comdial Corporation (the “Company”) and is
intended for the use of its customers and service personnel. The information in this
manual is subject to change without notice. While every effort has been made to
eliminate errors, the Company disclaims liability for any difficulties arising from the
interpretation of the information contained herein.

The information contained herein does not purport to cover all details or variations in
equipment or to provide for every possible contingency to be met in connection with
installation, operation, or maintenance. Should further information be desired, or
should particular problems arise which are not covered sufficiently for the purchaser’s
purposes, contact Comdial, Inside Sales Department, Charlottesville, Virginia 22906.
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